Ich kann das Forum nicht installieren (CF4)

 
Surle
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Franken
Beiträge: 40
Dabei seit: 01 / 2005
Betreff:

Ich kann das Forum nicht installieren (CF4)

 · 
Gepostet: 15.05.2019 - 18:51 Uhr  ·  #1
Guten Abend zusammen,

ich hatte das 2.0, cf3 und niemals Probleme. Nun habe ich CF4. Webspace befindet sich noch bei United Domains. Es ging schon damit an, dass ich Ws_FTP nicht mehr nutzen kann, ich bekomme einfach keine Verbindung. Irgendwas scheint mit dem Host nicht zu stimmen, welcher mir vom Support United Domains mitgeteilt wurde. Mit Filezilla geht es.

Ich lade alle Dateien hoch, Ordner belasse ich bei cf4, rufe setup auf "http://thelast.tk/cf4/setup/index.php" und bekomme folgendes Ergebnis:
The requested URL /cf4/setup/index.php was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Ich verstehe nicht was das bedeuten soll und bitte um Hilfe. Vielen Dank für jeden Tipp.

LG Anschi
Fragz
koffeeinsuechtiger coding freak
Avatar
Geschlecht:
Herkunft: Neuss
Alter: 36
Homepage: fragz.de
Beiträge: 2217
Dabei seit: 03 / 2008
Betreff:

Re: Ich kann das Forum nicht installieren (CF4)

 · 
Gepostet: 15.05.2019 - 21:56 Uhr  ·  #2
Surle
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Franken
Beiträge: 40
Dabei seit: 01 / 2005
Betreff:

Re: Ich kann das Forum nicht installieren (CF4)

 · 
Gepostet: 16.05.2019 - 09:26 Uhr  ·  #3
Hallo Fragz,

nachdem ich einiges anders verknüpft habe bei United Domains, kam ich auch zu dem Ergebnis, konnte das gestern aber nicht mehr schreiben. Gerade habe ich das Forum installiert und das ist das Ergebnis:

Fatal error: Uncaught Error: Class 'classes\board\BBCode' not found in /homepages/5/d4295008854/htdocs/cf4/classes/core/Core.class.php:689 Stack trace: #0 /homepages/5/d4295008854/htdocs/cf4/classes/controller/CoreError.class.php(129): classes\core\Core->show_header() #1 /homepages/5/d4295008854/htdocs/cf4/classes/controller/CoreError.class.php(86): CoreError::templated_output(2, '"continue" targ...', ' ', true) #2 /homepages/5/d4295008854/htdocs/cf4/classes/controller/CoreError.class.php(45): CoreError::route_error_message(2, '"continue" targ...', ' ', true) #3 /homepages/5/d4295008854/htdocs/cf4/includes/cback/autoload.php(59): CoreError::core_error_handler(2, '"continue" targ...', '/homepages/5/d4...', 252, Array) #4 /homepages/5/d4295008854/htdocs/cf4/includes/cback/autoload.php(59): require_once() #5 [internal function]: cback_autoloader('classes\\board\\B...') #6 /homepages/5/d4295008854/htdocs/cf4/index.php(59): spl_autoload_call('classes\\board\\B...') #7 {main} thrown in /homepages/5/d4295008854/htdocs/cf4/classes/core/Core.class.php on line 689

Ich werde jetzt Cache etc. noch einmal löschen, es noch einmal probieren und dann Bescheid geben. Danke Fragz für die Hilfe, alleine komme ich da nicht mehr weiter.

Viele Grüße
Anschi

Nachtrag: Ich habe es noch einmal probiert, gleiches Ergebnis. Ich hab mal einen Screenshot gemacht, vielleicht ist da was falsch drin. Die Prüfung ist übrigens okay, Es heißt am Ende ich soll die Startseite aufrufen und dann kommt obiger Text. Den Screenshot kriege ich auch nicht hoch. Irgendwie läuft jetzt alles schief. Sry, Screenshot ist da.
Der an diesem Beitrag angefügte Anhang ist entweder nur im eingeloggten Zustand sichtbar oder die Berechtigung Deiner Benutzergruppe ist nicht ausreichend.
Fragz
koffeeinsuechtiger coding freak
Avatar
Geschlecht:
Herkunft: Neuss
Alter: 36
Homepage: fragz.de
Beiträge: 2217
Dabei seit: 03 / 2008
Betreff:

Re: Ich kann das Forum nicht installieren (CF4)

 · 
Gepostet: 16.05.2019 - 16:45 Uhr  ·  #4
Grüß dich,

soweit sieht das richtig aus.
Hast du das aktuelle CF4 in der Version 4.5?
Welche PHP Version benutzt du?

In einer früheren Version des CF4 gab es Probleme mit dem BBCode bzw. Autoload sofern das unter PHP7.3 installiert wurde.
Ich habe gerade nicht im Kopf mit welcher Version dies behoben wurde, in der aktuelle Version taucht es aber nicht mehr auf.

LG,
Fragz
Surle
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Franken
Beiträge: 40
Dabei seit: 01 / 2005
Betreff:

Re: Ich kann das Forum nicht installieren (CF4)

 · 
Gepostet: 16.05.2019 - 18:07 Uhr  ·  #5
Guten Abend FragZ,

danke nochmals, dass du dich kümmerst. php habe ich 7.3. Die Software-Version kenne ich nicht, ich weiß nur cf4.XX. Das 4.50 dürfte ich nicht haben, da Kauf Ende Februar und das Update kam einen Monat später. Ich habe es mir geladen. Im Text dazu steht das mit den Probs bezüglich php 7.3. Aber wie soll ich das Update drüberspielen, wenn das Forum überhaupt nicht läuft?
Oder sollte ich vorübergehend auf php 7.1 oder 7.2 umstellen, wieder installieren und dann erst das Update aufspielen?

Entschuldige bitte die vielen Fragen, ich bin nicht lesefaul, probiere auch so ziemlich alles aus, aber manchmal fällt es mir älterem Semester schon ziemlich schwer da folgerichtig mitzudenken, vor allem wenn es jahrelang wie "geschmiert" läuft und dann gibt es auf einmal Probleme. :( Aber bevor ich php umstelle, warte ich lieber auf deine Antwort.

Herzlichen Dank und lG
Anschi
Fragz
koffeeinsuechtiger coding freak
Avatar
Geschlecht:
Herkunft: Neuss
Alter: 36
Homepage: fragz.de
Beiträge: 2217
Dabei seit: 03 / 2008
Betreff:

Re: Ich kann das Forum nicht installieren (CF4)

 · 
Gepostet: 16.05.2019 - 18:45 Uhr  ·  #6
HiHo,

Zitat
danke nochmals, dass du dich kümmerst.


Gerne.

Zitat
Die Software-Version kenne ich nicht, ich weiß nur cf4.XX. Das 4.50 dürfte ich nicht haben, da Kauf Ende Februar und das Update kam einen Monat später. Ich habe es mir geladen. Im Text dazu steht das mit den Probs bezüglich php 7.3. Aber wie soll ich das Update drüberspielen, wenn das Forum überhaupt nicht läuft?
Oder sollte ich vorübergehend auf php 7.1 oder 7.2 umstellen, wieder installieren und dann erst das Update aufspielen?


Wenn deine Lizenz nicht abgelaufen ist, die ist ja ein Jahr gültig, kannst du dir jederzeit im Kunden Login die aktuelle Version laden. Da es sich um eine Neuinstallation handelt, bitte das Komplettpacket herunterladen, dann fällt das Update weg.

Sollte deine Lizenz abgelaufen sein, versuch es mit PHP 7.2 bzw. 7.1.
Du wirst dann aber früher oder später deine Lizenz dennoch verlängern müssen. Erstens wegen der Sicherheit und zweitens gibt es diverse Plugins und Themes die nur mit der aktuellen Version funktionieren.

Code
Entschuldige bitte die vielen Fragen, ich bin nicht lesefaul, probiere auch so ziemlich alles aus, aber manchmal fällt es mir älterem Semester schon ziemlich schwer da folgerichtig mitzudenken, vor allem wenn es jahrelang wie "geschmiert" läuft und dann gibt es auf einmal Probleme.  :( Aber bevor ich php umstelle, warte ich lieber auf deine Antwort. 


Kein Problem, dafür ist das Supportforum ja vorhanden.

LG,
Christian
Surle
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Franken
Beiträge: 40
Dabei seit: 01 / 2005
Betreff:

Re: Ich kann das Forum nicht installieren (CF4)

 · 
Gepostet: 16.05.2019 - 20:11 Uhr  ·  #7
Guten Abend FragZ,

die Lizenz läuft bis 20.02.20, ist also noch gültig. Die Bezeichnung "Komplettpaket" finde ich nicht bei "Ihre aktivierten Lizenzen". Aber bei den Updatepaketen steht, dass man bei "Meine Lizenzen" das "Komplettpaket" laden soll. Also dürfte das der dortige Download sein.

Ich hoffe, dass ich das richtig verstanden habe. Ich habe bisher meinen ersten Download vom Februar 2019 verwendet, also eine frühere Version. Nach dem Kauf im Februar 19 kam ein unerwünschter Kliniktest und ich habe erst dieser Tage wieder mit dem Forum angefangen und aus Bequemlichkeit einfach den damaligen Download verwendet. Ich werde es jetzt mit der aktuellen Version versuchen.

Ich melde mich, ob es geklappt hat oder nicht.

LG und herzlichen Dank
Anschi
Fragz
koffeeinsuechtiger coding freak
Avatar
Geschlecht:
Herkunft: Neuss
Alter: 36
Homepage: fragz.de
Beiträge: 2217
Dabei seit: 03 / 2008
Betreff:

Re: Ich kann das Forum nicht installieren (CF4)

 · 
Gepostet: 16.05.2019 - 20:24 Uhr  ·  #8
Ah ok, mein Fehler. Ich meine natürlich Meine Lizenzen.

Zitat
Ich habe bisher meinen ersten Download vom Februar 2019 verwendet, also eine frühere Version.


Im März kam die neue Version ;-)
Gewählte Zitate für Mehrfachzitierung:   0

Registrierte in diesem Topic

Aktuell kein registrierter in diesem Bereich

Die Statistik zeigt, wer in den letzten 5 Minuten online war. Erneuerung alle 90 Sekunden.