Fehlerhafte Benachrichtigungen

 
Uwe Hallenga
Benutzer
Avatar
Geschlecht:
Alter: 61
Homepage: kleinwindanlagen.d…
Beiträge: 148
Dabei seit: 05 / 2009
Betreff:

Fehlerhafte Benachrichtigungen

 · 
Gepostet: 10.05.2020 - 14:59 Uhr  ·  #1
Moin Moin

normalerweise bekomme ich von allen Beiträgen die ich selbst geschrieben oder die ich abonniert habe eine entsprechende Nachricht über einen neuen Beitrag.

Dem ist scheinbar aus irgendeinem Grund nicht mehr so und es geht nicht nur mir so sondern einigen anderen meiner ForumsUsern auch. Und dann auch noch nicht immer gleich, sondern mal kommt eine Nachricht und mal nicht.

Hat jemand ne Idee woran das liegen könnte und wie man das beheben kann?

Gruß Uwe
(Bleibt Gesund)
cback
Admin
Avatar
Geschlecht:
Herkunft: Saarland
Alter: 36
Homepage: cback.de
Beiträge: 17539
Dabei seit: 12 / 2003
Betreff:

Re: Fehlerhafte Benachrichtigungen

 · 
Gepostet: 13.05.2020 - 13:55 Uhr  ·  #2
Moin Uwe,

also da Du sagst das Verhalten hat sich geändert und es ist nur "sporadisch" falsch schließe ich schon mal einen Bedienfehler oder Einstellungsfehler im CF4 direkt hier aus. Nur zur Sicherheit aber nochmal kurz die Übersicht wie die Abomails normalerweise funktionieren:

- Wenn man ein Forum abonniert, erhält man nur eine Mail, sobald in dem abonnierten Forum ein neues Thema erstellt wurde. Wenn man diese Themen dann nicht extra als Themenabo abonniert erhält man keine weiteren Mails. Dies dient dazu, dass sich die Mailmenge nicht irgendwann durch Forenabos und eventuell inaktive Accounts mit dem Automatismus ins unermessliche hochschaukeln.

- Beim Themenabo bekommst Du eine E-Mail, sobald eine Antwort geschrieben wurde. Bis Du das Thema dann einmal wieder aufgerufen hast erhälst Du erst einmal keine weiteren Mails bei weiteren Antworten mehr. Dies verhindert, dass Du z.B. bei sehr aktiven Themen Abends nach Hause kommst und das Mailfach voller "neue Antwort auf" Mails oder schlimmer noch durch die Mailmasse wird Dein Spamfilter darauf trainiert Forenmails künftig zu ignorieren oder Mailanbieter striken Deine Seite wegen zu hoher Mailmasse. Also es kommt eine Benachrichtigung, dann Pause bis Du gelesen hast, dann wieder eine sobald eine neue Antwort kommt (automatisch). Der Text der Antwort steht daher auch nicht in der Mail sodass man gezwungen ist das Thema per Klick aufzurufen und erst dann eben auch eventuell weitere Antworten nach der Benachrichtigung sieht. ;)


Die Themen und Forenabos kannst Du jederzeit im UserCP unter "Abonnements" ansehen und bearbeiten. Dort siehst Du auch, ob Du wirklich das E-Mail Abo eingeschaltet hast oder nicht. Und unter UserCP => Einstellungen kannst Du sowohl einstellen, ob Themen beim Antworten automatisch abonniert werden und ob es nur ein forenbasiertes Abo sein soll oder eben eins mit Mails.



Aber nun zu dem was ich bei Dir als Problemursache vermute:
Du sagst ja, dass es mal geht und mal nicht und das andere User genau so betroffen sind. Das deutet darauf hin, dass das Problem vielleicht durch Deinen Hoster entsteht.

Deine Webseite liegt auf geteiltem / shared Host. Viele Hoster setzen - um Spam durch Schadscripte zu vermeiden - hier auf E-Mail Kontingente. Entweder wird die Anzahl der Mails pro Tag von Scripten generell limitiert und/oder die Anzahl der Empfänger die ein Script gleichzeitig "befeuern" darf.

Das könnte Dein Phänomen dann erklären. Beispiel:

Ein Thema hab nur 2 Abonnenten => liegt noch unter der Hostergrenze, Mail geht raus

Ein anderes Thema hat vielleicht 20 Abonnenten => er will bis zu 20 Mailadressen "befeuern", die Grenze des Hosters lehnt die Mail ab.

Da diese Grenzen meist auf Mailserverebene stattfinden ist es auch üblich, dass auf PHP Seite erst einmal keine Fehlermeldung entsteht: Für das Script ging die Mail ja erst einmal an den "Boten" weiter, nur hat der Bote dann aufgrund der Schutzmechanismen des Hosters keine Lust es auch zuzustellen mal salopp gesagt.

Ich würde also mal Deinen Hoster fragen, ob Du bezüglich limitierungen von Mails durch Scripten hier Werte gesetzt hast und diese erhöhen oder aufheben lassen. Das CF4 sendet ja nur legitime Mails und kann nicht für Mailspam missbraucht werden (Mailadressen werden verifiziert beim Registrieren wenn Du das weiter so eingestellt hast, beim Ändern der Mailadresse muss man auch bestätigen, User können keine Mails über das Forum selbst verschicken und Dinge wie Themenabos kann jeder User selbst steuern).


Hoffe das hilft Dir!

LG und bleib auch gesund,
Chris
Uwe Hallenga
Benutzer
Avatar
Geschlecht:
Alter: 61
Homepage: kleinwindanlagen.d…
Beiträge: 148
Dabei seit: 05 / 2009
Betreff:

Re: Fehlerhafte Benachrichtigungen

 · 
Gepostet: 14.05.2020 - 11:00 Uhr  ·  #3
Danke ich werde das prüfen und bei Nachricht hier auch nochmal posten.

Bleibt gesund
Uwe
Mimi
Benutzer
Avatar
Geschlecht:
Alter: 38
Beiträge: 89
Dabei seit: 05 / 2017
Betreff:

Re: Fehlerhafte Benachrichtigungen

 · 
Gepostet: 05.06.2020 - 22:07 Uhr  ·  #4
Hallo Uwe!

Hast du herausbekommen, wo die Ursache für die fehlerhafte Benachrichtung lag?
Ich habe dieses Phänomen leider auch.
Bei meinem Forum sind die User betroffen, die eine Mailadresse bei web.de oder gmx.de haben.
Ich stehe bereits mit dem Hoster in Kontakt, leider bisher ohne Ergebnis.
Freue mich, wenn du deine Erkenntnisse teilst.
Danke schon einmal!
cback
Admin
Avatar
Geschlecht:
Herkunft: Saarland
Alter: 36
Homepage: cback.de
Beiträge: 17539
Dabei seit: 12 / 2003
Betreff:

Re: Fehlerhafte Benachrichtigungen

 · 
Gepostet: 28.10.2020 - 14:22 Uhr  ·  #5
Gewählte Zitate für Mehrfachzitierung:   0

Registrierte in diesem Topic

Aktuell kein registrierter in diesem Bereich

Die Statistik zeigt, wer in den letzten 5 Minuten online war. Erneuerung alle 90 Sekunden.