Fatal error: Uncaught Error: Class 'classes\board\BBCode'

 
Kiana
Benutzer
Avatar
Geschlecht:
Alter: 29
Beiträge: 28
Dabei seit: 06 / 2018
Betreff:

Fatal error: Uncaught Error: Class 'classes\board\BBCode'

 · 
Gepostet: 24.03.2019 - 03:38 Uhr  ·  #1
Hallo,

bei einer Neuinstallation des CF4 stoße ich direkt nach der Installation auf eine Fatal Error Meldung und ich kann sie nicht entschlüsseln, kenne mich da nicht so gut aus leider.

Aus diesem Grund bräuchte ich da bitte Hilfe. Die folgende Meldung sieht exakt so aus:

Code
Fatal error: Uncaught Error: Class 'classes\board\BBCode' not found in /customers/0/f/1/sturmdrachen.de/httpd.www/classes/core/Core.class.php:689 Stack trace: #0 /customers/0/f/1/sturmdrachen.de/httpd.www/classes/controller/CoreError.class.php(129): classes\core\Core->show_header() #1 /customers/0/f/1/sturmdrachen.de/httpd.www/classes/controller/CoreError.class.php(86): CoreError::templated_output(2, '"continue" targ...', ' ', true) #2 /customers/0/f/1/sturmdrachen.de/httpd.www/classes/controller/CoreError.class.php(45): CoreError::route_error_message(2, '"continue" targ...', ' ', true) #3 /customers/0/f/1/sturmdrachen.de/httpd.www/includes/cback/autoload.php(59): CoreError::core_error_handler(2, '"continue" targ...', '/customers/0/f/...', 252, Array) #4 /customers/0/f/1/sturmdrachen.de/httpd.www/includes/cback/autoload.php(59): require_once() #5 [internal function]: cback_autoloader('classes\\board\\B...') #6 /customers/0/f/1/sturmdrachen.de/httpd.www/index.php(59): spl_autoload_call('classes\\board\\B...') #7 in /customers/0/f/1/sturmdrachen.de/httpd.www/classes/core/Core.class.php on line 689


Kann man sich auch gerne live auf https://sturmdrachen.de/ ansehen.



Liebe Grüße
Kiana
Iridion
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 22
Dabei seit: 07 / 2017
Betreff:

Re: Fatal error: Uncaught Error: Class 'classes\board\BBCode'

 · 
Gepostet: 24.03.2019 - 21:20 Uhr  ·  #2
Hallo!

Hast Du alle Dateien denn richtig hochgeladen und abrufbar? Oder ist da beim Upload vielleicht was kaputt gegangen?
Ich glaub die Meldung sagt, dass er irgendwas im classes Ordner nicht öffnen kann.

Musst mal schauen, ob Dein Hoster ein Limit für parallele Uploads beim FTP hat, das hatte nämlich mal bei mir da musste ich von 6 gleichzeitig hochladen bei FTP auf 1 stellen beim hochladen, sonst waren alle Bilder weg. :D
Kiana
Benutzer
Avatar
Geschlecht:
Alter: 29
Beiträge: 28
Dabei seit: 06 / 2018
Betreff:

Re: Fatal error: Uncaught Error: Class 'classes\board\BBCode'

 · 
Gepostet: 24.03.2019 - 22:12 Uhr  ·  #3
Hallo,

das weiß ich so genau gar nicht. Das müsste ich dann mal ausprobieren und zusätzlich mit dem Support des Hostingservice besprechen. Ich melde mich danach wieder. ^^

Edit: Hatte das gleichzeitige Hochladen testweise auf 1 gestellt, aber es kamen alle Dateien rüber, ansonsten wäre vermutlich die eine oder andere Datei aufgelistet gewesen. In FileZilla gibt es schließlich extra einen Reiter für fehlgeschlagene Uploads.
cback
Admin
Avatar
Geschlecht:
Herkunft: Saarland
Alter: 36
Homepage: cback.de
Beiträge: 17539
Dabei seit: 12 / 2003
Betreff:

Re: Fatal error: Uncaught Error: Class 'classes\board\BBCode'

 · 
Gepostet: 25.03.2019 - 15:21 Uhr  ·  #4
Hallo,

ich klink mich mal kurz ein:

Das neu hochladen der Datei bei obiger Fehlermeldung (Autoload fehlgeschlagen) ist übrigens ein absolut guter und richtiger Tipp gewesen! Der Autoload sollte nämlich eigentlich immer funktionieren sofern die Systemanforderungen (PHP5.6 oder höher, am Besten was aus der 7er Sektion) erfüllt sind. Und falls die PHP Version nicht passt müsste normal eine ganz andere Fehlermeldung kommen. ("Forum braucht mindestens...").

Ich sehe aktuell hast Du allerdings noch eine ganz andere Fehlermeldung auf der Seite als die von oben. Ich sehe aber auch noch einen Konfigurationsfehler bezüglich des Server-Ports (er versucht immer auf die 80 zu springen, vermutlich das setup ohne https ausgeführt und hier klemmt noch was). Ich denke mal das spielt hier u.U. auch noch eine Rolle, allerdings würde ich mir - sofern Du erlaubst - das gerne mal kurz "vor Ort" ansehen ob es vielleicht darüber hinaus noch ein Kompatibilitätsproblem mit dem Hoster sein kann, welches ich in der Software künftig optimieren könnte.

Sofern Du erlaubst wäre es nett, wenn Du mir die FTP Zugangsdaten und Zugang zur Datenbank (phpMyAdmin falls vorhanden) senden könntest (per PM hier). Falls Dein Hoster kein phpMyAdmin installiert hat ist das auch nicht schlimm, dann reicht der FTP Zugang.

Du hast zwar nur die Basic, aber für Dich fallen dafür dann trotzdem keine zusätzlichen Kosten an: Das vor Ort gucken dient mitunter dazu die Software auf noch mehr Hostern kompatibel zu machen. Und falls es nur an der Config lag bieg' ich Dir das fix gerade und es ist auch alles paletti. ;)


LG,
Chris
Gewählte Zitate für Mehrfachzitierung:   0

Registrierte in diesem Topic

Aktuell kein registrierter in diesem Bereich

Die Statistik zeigt, wer in den letzten 5 Minuten online war. Erneuerung alle 90 Sekunden.